返回列表 发帖

重分布的路由抖动问题

拓扑如附件 对isis 和rip进行重分布,配置如下,当配置为红字时,R2上的R3路由会出现抖动(一会通过isis学到,一会儿通过rip学到)改为蓝字,则总是通过rip学到,是什么原因?isis的管理距离优于rip,在rip中重分布isis,按理会选择isis路由,为何稳定后选择的是rip路由?

R1:
Building configuration...

Current configuration : 1051 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.2.161 255.255.255.240 secondary
ip address 10.1.2.225 255.255.255.240 secondary
ip address 10.1.3.1 255.255.255.0 secondary
ip address 10.1.1.1 255.255.255.0
ip router isis
ipv6 address 2001B8:0:11::1/64
ipv6 address 2001B8:0:13::1/64
ipv6 address 2001B8:0:12A::1/64
ipv6 address 2001B8:0:12B::1/64
ipv6 router isis
!
interface FastEthernet0/0
ip address 10.1.4.1 255.255.255.0
ip router isis
duplex half
ipv6 address 2001B8:0:14::1/64
ipv6 router isis
!
router isis
net 00.0001.0000.0000.0001.00
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end


R2:
Building configuration...

Current configuration : 1082 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.4.2 255.255.255.0
ip router isis
duplex half
ipv6 address 2001B8:0:14::2/64
ipv6 router isis
!
interface FastEthernet1/0
ip address 10.2.1.2 255.255.255.0
duplex half
ipv6 address 2001B8:0:21::2/64
ipv6 rip r2r3 enable
!
router isis
net 00.0001.0000.0000.0002.00
redistribute rip level-1-2 (改成redistribute rip level-2 后正常)
!
address-family ipv6
redistribute rip r2r3 metric 0 level-1-2
exit-address-family
!
router rip
version 2
redistribute isis level-1-2 metric 1
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
!
ipv6 router rip r2r3
redistribute isis metric 1 level-1-2
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end


R3Building configuration...

Current configuration : 811 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.2.2.3 255.255.255.0
ipv6 address 2001B8:0:22::3/64
ipv6 rip r2r3 enable
!
interface FastEthernet0/0
ip address 10.2.1.3 255.255.255.0
duplex half
ipv6 address 2001B8:0:21::3/64
ipv6 rip r2r3 enable
!
router rip
version 2
network 0.0.0.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
!
ipv6 router rip r2r3
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end

14581_拓扑.JPG

Re: 重分布的路由抖动问题

See notes:
router isis
net 00.0001.0000.0000.0002.00
redistribute rip level-1-2 (RIP does NOT have two levels, so this command should NOT work. To avoid confusion, use simply 'redistribute rip')
!
address-family ipv6
redistribute rip r2r3 metric 0 level-1-2 (redistribute RIP routes into ISIS with metric of 0, route from R1 to R2 has metric of 10 by default if no change has been made, while route from R1 to R2 to R3 to R2 is 0, therefore, this route is going to get precedence over the previous route. Create suboptimal routing)
exit-address-family
!
router rip
version 2
redistribute isis level-1-2 metric 1
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
!
ipv6 router rip r2r3
redistribute isis metric 1 level-1-2
One thing to note is that you should ALWAYS give redistributed routes a MUCH higher metric so the route is only going to be used when no other routes are available.

See notes:

router isis

net 00.0001.0000.0000.0002.00

redistribute rip level-1-2 (RIP does NOT have two levels, so this command should NOT work. To avoid confusion, use simply 'redistribute rip')

!

address-family ipv6

redistribute rip r2r3 metric 0 level-1-2 (redistribute RIP routes into ISIS with metric of 0, route from R1 to R2 has metric of 10 by default if no change has been made, while route from R1 to R2 to R3 to R2 is 0, therefore, this route is going to get precedence over the previous route. Create suboptimal routing)

exit-address-family

!

router rip

version 2

redistribute isis level-1-2 metric 1

network 10.0.0.0

no auto-summary

!

ip classless

no ip http server

no ip http secure-server

!

!

ipv6 router rip r2r3

redistribute isis metric 1 level-1-2

One thing to note is that you should ALWAYS give redistributed routes a MUCH higher metric so the route is only going to be used when no other routes are available.

TOP

Re: 重分布的路由抖动问题

你在R1上的ISIS协议进程下输入:redistribute isis ip level-1 into level-2 distribute-list 100;然后到全局配置模式下输入:access-list 100 deny ip any any 就可以了;默认是把所有LEVEL-1库里的路由都转存到LEVEL-2里;你使用一个ACL过滤下;

原因是

如果在R2上把RIP路由同时以level-1-2的形式进入ISIS的话,那么在R1上,通过LEVEL-1学到的R3上的路由后,R1会自动把它转到LEVEL-2的DATABAS里,然后R1通过和R2之间的LEVEL-2的邻居关系把路由又通告回给R2,所以在R2上看到R3上的路由是通过ISIS的L2学到的;由于这个原因,那么R2上把RIP重分布进ISIS的动作也会停止,停止后,R1又学不能够从R2学到R3的路由了,所以就会把之前的R3重分布进的的路由从LEVEL-1的库里删除,同时也会从LEVEL-2的库里删除,同时R2就不能从R1学到R3被重分布进来的路由了;过一个RIP周期后,R3又把它的路由通告给R2,那么重分发动作又开始执行;这个过程会反复:在R2上,一开始R3的路由以R的形式出现,过会儿以I L2形式形式出现,吓一跳是R1,再过会儿又没有;反复这样

如果让RIP路由只以LEVEL-2的形式入ISIS的话,那么R1的LEVEL-1的DATABASE里就没有RIP重分布进的路由了,所以也就不会转到LEVEL-2的DATABASE里了;所以会一切正常;

TOP

返回列表 回复 发帖