返回列表 发帖

CCNA考试IOS命令大全


给出一个帮助屏幕
0.0.0.0 255.255.255.255 通配符命令;作用与any命令相同
access-class 将标准的IP访问列表应用到VTY线路
access-list 创建-个过滤网络的测试列表
any 指定任何主机或任何网络;作用与0.0.0.0 255.255.255.255命令相同
Backspace 删除一个字符
Bandwidth 设置--个串行接口止的带宽
Banner 为登录到本路由器上的用户创建--个标志区
cdp enable 打开-个特定接口的CDP
cdp holdtime 修改CDP分组的保持时间
cdp run 打开路由器上的CDP
cdp timer 修改CDP更新定时器
clear counters 清除某一接口上的统计信息
clear line 清除通过Telnet连接到路由器的连接
clear mac-address-table 清除该交换机动态创建的过滤表
clock rate 提供在串行DCE接口上的时钟
config memory 复制startup-config到running-config
config network 复制保存在TFTP主机上的配置到running-config
config terminal 进人全局配置模式并修改running-config
config-register 告诉路由器如何启动以及如何修改配置寄存器的设置
copy flash tftp 将文件从闪存复制到TFTP主机
copy run start copy running-config startup-config的快捷方式,将配置复制到NVRAM中
copy run tftp 将running-config文件复制到TFTP主机
Copy tftp flash 将文件从TFTP主机复制到闪存
Copy tftp run 将配置从TFTP主机复制为running-config文件
Ctrl+A 移动光标到本行的开始位置
Ctrl+D 删除一个字符
Ctrl+E 移动光标到本行的末尾
Ctrl+F 光标向前移动一个字符
Ctrl+R 重新显示一行
Ctrl+Shitf+6,then X 当telnet到多个路由器时返回到原路由器
Ctrl+U 删除一行
Ctrl+W 删除一个字
CTRL+Z 结束配置模式并返回EXEC(执行状态)
debug dialer 显示呼叫建立和结束的过程
debug frame-relay lmi 显示在路由器和帧中继交换机之间的lmi交换信息
debug ip igrp events 提供在网络中运行的IGRP路由选择信息的概要
debug ip igrp transactions 显示来自相邻路由器要求更新的请求消息和由路由器发到相邻路由器的广播消息
debug ip rip 发送控制台消息显示有关在路由器接口上收发RIP数据包的信息
debug ipx 显示通过路由器的RIP和SAP信息
debug isdn q921 显示第二层进程
debug isdn q931 显示第三层进程
delete nvram 删除1900交换机-NVRAM的内容
delete vip 删除交换机的VTP配置
description 在接口上设置---个描述
dialer idle-timeout number 告诉BRI线路如果没有发现触发DDR的流量什么时候断开
dialer list number protocol 为DDR链路指定触发DDR的流量
protocol permit/deny
dialer load-threshold number 设置描述什么时候在ISDN链路上启闭第二个BRI的参数
inbound/outbound/either
Dialer map protocol address 代替拨号串用于作ISDN网络中提供更好的安全性
name hostname number
dialer string 设置用于拨叫BRl接口的电话号码
disable 从特权模式返回用户模式
disconnect 从原路由器断开同远楞路由豁的连接
dupler 设置一个接口的双工
enable 进入特权模式
enable password 设置不加密的启朋口令
enable password level 1 设置用户模式口令
enable password level 15 设置启用模式口令
enable secret 设置加密的启用秘密口令。如果设置则取代启用口令
encapsulation 在接口上设置帧类型
encapsulation frame-relay 修改帧中继串行链路上的封装类型
encapsulation frame-relay 将封装类型设置为因特网工程任务组 (IETF,Internet Enginering Task Force)类型。连接Cisco路由器和非Cisco路由器
encapuslation hdlc 恢复串行路由器的默认封装HDLC
encapuslation isl 2 为VLAN 2设置ISL路由
encapuslation ppp 将串行链路上的封装修改为PPP
erase starup 删除startup-config
erase starup-config 删除路由器上的NVRAM的内容
Esc+B 向后移动一个字
Esc+F 向前移动一个字
exec-timeout 为控制台连接设置以秒或分钟汁的超时
exit 断开远程路由器的Teln讨连接
frame-relay interface-dlci 在串行链路或子接口上配置PVC地址
frame-relay lmi-type 在串行链路上配置LMI类型
frame-relay map protocl 创建用于帧中继网络的静态映射
Host 指定一个主机地址
Hostname 设置一台路由器或交换机的名字
int e0.10 创建一个子接口
int f0/0.1 创建一个子接口
interface 进入接口配置模式
interface e0/5 配置Ethernet接口5
interface ethernet 0/1 配置接口e0/1
interface f0/26 配置Fast Ethernet接口26
interface fastehernet 进人Fast Ethernet端口的接口配置模式
interface fastethernet 0/0.1 创建一个子接口
interface fastethernet0/26 配置接口f0/26
interface s0.16 multipoint 在串行链路上创建用于帧中继网络的多点子接口
interface s0.16 point-to-point 在串行链路上创建用于帧中继网络的点对点子接interface serial 5 进人接口serial 5的配置模式,也可以使用show命令
ip access-group 将IP访问列表应用到一个接口
ip address 设置一个接口或交换机IP地址
ip classless 一个全局配置命令,用于告诉路由器当目的网络没有出现在路由表中时通过默认路由转发数据包
ip default-gateway 设置该交换机的默认网关
ip domain-lookup 打开DNS查找功能 (默认时打开)
ip domain-name 将域名添加到DNS查找名单中
ip host 在路由器上创建主机表
ip name-server 最多设置6个DNS服务器的IP地址
Ip route 在路由器上创建静态和默认路由
ipx access-group 将IPX访问列表应用到一个接口
ipx input-sap-filter 将输入型IPX SAP过滤器应用到一个接口
ipx network 为接口分配IPX网络号
ipx output-sap-filter 将输出型IPX SAP过滤器应用到一个接口
ipx ping 用于测试互联网络上IPX包的因特网探测器
ipx routing 打开IPX路由
isdn spidl 为ISDN交换机设置标识第一个DSO的号码
isdn spid2 为ISDN交换机设置标识第二个DSO的号码
isdn switch-type 设置路由器与之通信的ISDN交换类型。可以往接口模式和全局配置模式下设
K 用在1900交换机启动时并将该交换机置于CLI模式
Line 进入配置模式以修改和设置用户模式口令
line aux 进入辅助接口配置模式
line console 0 进入控制台配置模式
line vty 进入VTY(Telnet)接口配置模式
logging synchronous 阻止控制台信息覆盖命令行上的输入
logout 退出控制台会话
mac-address-table permanent 在过滤数据库中生成一个永久MAC地址
mac-addres-table resticted 在MAC过滤数据库中设置一个有限制的地址,只允许所配置的接口与有限制的地址通信
media-type 在接口上设置硬件介质体类型
network 告诉路由选择协议要发通告的网络
no cdp run 关闭单个接口上的CDP
no inverse-arp 完全关闭路由器上的CDP
no inverse 关闭帧中继中的动态IARP。必须已配置了静态映射
no ip domain-lookup 关闭DNS查找功能
no ip host 从主机表删除一个主机名
No IP route 删除静态或默认路由
no shutdown 打开一个接口
o/r Ox2142 修改2501以便启动时不使用NVRAM的内容
ping 测试一个远程设备的IP连通性
port secure max-mac-count 只允许配置的设备量连接并在一个接D上工作
ppp authentucation chap 告诉PPP使用CHAP认证方式
ppp authentucation pap 告诉PPP使用PAP认证方式
router igrp as 在路由器上打开IP IGRP路由选择
router rip 使用户进人路由器rip配置模式
secondary 在同一个物理接口上添加辅助IPX网络
Service password-encryption 加密用户模式和启用口令
show access-list 显示路由器上配置的所有访问列表
show access-list 110 只显示访问列表110
show cdp 显示CDP定时器和保持时间周期
show cdp entry * 同show cdpneighbordetail命令一样,但不能用于1900交换机
show cdp interface 显示启用了CDP的特定接口
show cdp neighbor 显示直连的相邻设备及其详细信息
show cdp neighbor detail 显示IP地址和IOS版本和类型,并且包括show cdp
neighbor命令显示的所有信息
show cdp traffic 显示设备发送和接收的CDP分组数以及任何出错信息
Show controllers s 0 显示接口的DTE或DCE状态
show dialer 显示拨号串到达的次数、B信道的空闲超时时间值、呼
叫长度以及接口所连接的路由器的名称
show flash 显示闪存中的文件
show frame-relay Imi 在串行接口上设置LMI类型
show frame-relay map 显示静态的和动态的网络层到PVC的映射
show frame-relay pvc 显示路由器上己配置的PVC和DLCI号
show history 默认时显示最近输人的10个命令
show hosts 显示主机表中的内容
show int fO/26 显示抑/26的统汁
show inter e0/l 显示接口e0/l的统计
show interface S0 显示接口serial上的统计信息
show ip 显示该交换机的IP配置
show ip access-list 只显示IP访问列表
show ip interface 显示哪些接口应用了IP访问列表
show ip interface 显示在路由器上配置的路由选择协议及与每个路由选择协议相关的定时器
show ip route 显示IP路由表
show ipx access-list 显示路由器上配置的IPX访问列表
trunk on 将一个端口设为永久中继模式 "
usemame name password 为了Cisco路由器的身份验证创建用户名和口令
variance 控制最佳度量和最坏可接受度量之间的负载均衡
vlan 2 name Sales 创建一个名为Sales的VLAN2
lan-membership static 2 给端口分配一个静态VLAN
vtp client 将该交换机设为一个VTP客户
vtp domain 设置为该VTP配置的域名
vtp password 在该VTP域上设置一个口令
vtp pruning enable 使该交换机成为一台修剪交换机
vtp server 将该交换机设为一个VTP服务器
show ipx interface 显示一个特定接口上发送和接收的RIP和SAP信息
show ipx servers 显示接口的IPX地址
show ipx route 显示IPX路由表
show ipx traffic 显示Cisco路由器的SAP表
show ipx traffic 显示Cisco路由器上发送和接收的RIP和SAP信息
show isdn active 显示呼叫的号码和呼叫是否在进行中
show isdn status 显示SPID是否有效、是否己连接以及和提供商交换机的通信情况
show mac-address-table 显示该交换机动态创建的过滤表
show protocols 显示在每个接口上配置的被动路由协议和网络地址
show run showrunning-config的缩写,显示当前在该路由器上运行的配置
show sessions 显示通过Telent到远程设备的连接
show start 命令show startup-config的快捷方式。显示保存在
NVRAM中的备份配置
show terminal 显示配置的历史记录
show trunk A 显示端口26的中继状态
show trunk B 显示端口27的中继状态
show version 给出该交换机的IOS信息以及正常运行时间和基本
Ethernet地址
show vlan 显示所有己配置的VLAN
show vlan-membership 显示所有端口的VLAN分配
show vtp 显示一台交换机的VTP配置
shoutdown 设置接口为管理性关闭模式
Tab 为操作者完成命令的完整输入
telnet 连接、查看并在远程设备上运行程序
terminal history size 改变历史记录的大小由默认的10改为256
trace 测试远程设备的连通性并显示通过互联网络找到该远程设备的路径
traffic-share balanced 告诉IGRP路由选择协议要反比于度量值分享链路
traffic-share min 告诉IGRP路由选择协议要使用只有最小开销的路由
trunk auto 将该端口设为自动中继模式

Re: CCNA考试IOS命令大全

命令集比较老了

IGRP的相关命令已经用不着了

encapsulation hdlc也一般用不上,因为串口的默认封装就是hdlc了

CCNA中也不会考ipx的命令

TOP

返回列表 回复 发帖